Split webif into several packages for language files, closes #722
authorFlorian Fainelli <florian@openwrt.org>
Sun, 3 Sep 2006 20:24:38 +0000 (20:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 3 Sep 2006 20:24:38 +0000 (20:24 +0000)
SVN-Revision: 4743

17 files changed:
openwrt/package/webif/Config.in
openwrt/package/webif/Makefile
openwrt/package/webif/ipkg/webif-lang-ca.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-cz.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-de.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-dk.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-ee.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-es.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-fr.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-hr.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-hu.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-it.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-nl.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-no.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-pl.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-ru.control [new file with mode: 0644]
openwrt/package/webif/ipkg/webif-lang-se.control [new file with mode: 0644]

index e96373006548dc9ea114f7d59a2278a53c449141..ed636dde68c8e565a3dbbd9e5ae90f62357993aa 100644 (file)
@@ -1,3 +1,5 @@
+menu "webif - OpenWrt Administrative Console"
+
 config BR2_PACKAGE_WEBIF
        select BR2_PACKAGE_HASERL
        tristate "webif - OpenWrt Administrative Console"
@@ -5,3 +7,123 @@ config BR2_PACKAGE_WEBIF
        help
          A web interface for configuring OpenWrt
          
+config BR2_PACKAGE_WEBIF_LANG_CA
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-ca - Canadian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Canadian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_CZ
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-cz - Czech language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Czech language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_DE
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-de - German language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         German language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_DK
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-dk - Danish language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Danish language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_EE
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-ee - Estonian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Estonian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_ES
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-es - Spanish language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Spanish language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_FR
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-fr - French language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         French language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_HR
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-hr - Croatian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Croatian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_HU
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-hu - Hungarian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Hungarian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_IT
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-it - Italian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Italian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_NL
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-nl - Dutch language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Dutch language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_NO
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-no - Norwegian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Norwegian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_PL
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-pl - Polish language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Polish language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_RU
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-ru - Russian language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Russian language file for webif
+
+config BR2_PACKAGE_WEBIF_LANG_SE
+       select BR2_PACKAGE_HASERL
+       tristate "webif-lang-se - Swedish language file for webif"
+       depends BR2_PACKAGE_WEBIF
+       default m
+       help
+         Swedish language file for webif
+endmenu
index a3ae5712c8979fdee51bf5cac4d42270b105028e..d216e1cc22dec1b0873b9652b80d726564cec008 100644 (file)
@@ -13,7 +13,48 @@ NVRAM_OPTS=-DNVRAM -lnvram -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib
 
 include $(TOPDIR)/package/rules.mk
 
+define PKG_mod_template
+
+$$(IPKG_$(1)):
+       [ -z "$(2)" ] || install -d -m0755 $$(IDIR_$(1))/usr/lib/webif/lang/$(2)
+       cp -fpR ./files/usr/lib/webif/lang/$(2)/common.txt $$(IDIR_$(1))/usr/lib/webif/lang/$(2)/
+       $(RSTRIP) $$(IDIR_$(1))
+       $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
+
+endef
+
 $(eval $(call PKG_template,WEBIF,webif,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_CA,webif-lang-ca,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_CZ,webif-lang-cz,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_DE,webif-lang-de,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_DK,webif-lang-dk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_EE,webif-lang-ee,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_ES,webif-lang-es,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_FR,webif-lang-fr,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_HR,webif-lang-hr,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_HU,webif-lang-hu,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_IT,webif-lang-it,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_NL,webif-lang-nl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_NO,webif-lang-no,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_PL,webif-lang-pl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_RU,webif-lang-ru,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,WEBIF_LANG_SE,webif-lang-se,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(eval $(call PKG_mod_template,WEBIF_LANG_CA,ca))
+$(eval $(call PKG_mod_template,WEBIF_LANG_CZ,cz))
+$(eval $(call PKG_mod_template,WEBIF_LANG_DE,de))
+$(eval $(call PKG_mod_template,WEBIF_LANG_DK,dk))
+$(eval $(call PKG_mod_template,WEBIF_LANG_EE,ee))
+$(eval $(call PKG_mod_template,WEBIF_LANG_ES,es))
+$(eval $(call PKG_mod_template,WEBIF_LANG_FR,fr))
+$(eval $(call PKG_mod_template,WEBIF_LANG_HR,hr))
+$(eval $(call PKG_mod_template,WEBIF_LANG_HU,hu))
+$(eval $(call PKG_mod_template,WEBIF_LANG_IT,it))
+$(eval $(call PKG_mod_template,WEBIF_LANG_NL,nl))
+$(eval $(call PKG_mod_template,WEBIF_LANG_NO,no))
+$(eval $(call PKG_mod_template,WEBIF_LANG_PL,pl))
+$(eval $(call PKG_mod_template,WEBIF_LANG_RU,ru))
+$(eval $(call PKG_mod_template,WEBIF_LANG_SE,se))
 
 $(PKG_BUILD_DIR)/.prepared:
        mkdir -p $(PKG_BUILD_DIR)
@@ -30,6 +71,7 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_WEBIF): 
        cp -a ./files/* $(IDIR_WEBIF)/
+       rm -rf $(IDIR_WEBIF)/usr/lib/webif/lang/
        install -d $(IDIR_WEBIF)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/webif-page $(IDIR_WEBIF)/usr/bin/webif-page
        install -m0755 $(PKG_BUILD_DIR)/bstrip $(IDIR_WEBIF)/usr/bin/bstrip
diff --git a/openwrt/package/webif/ipkg/webif-lang-ca.control b/openwrt/package/webif/ipkg/webif-lang-ca.control
new file mode 100644 (file)
index 0000000..8bc767e
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-ca
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Canadian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-cz.control b/openwrt/package/webif/ipkg/webif-lang-cz.control
new file mode 100644 (file)
index 0000000..f04a161
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-cz
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Czech language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-de.control b/openwrt/package/webif/ipkg/webif-lang-de.control
new file mode 100644 (file)
index 0000000..9567325
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-de
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: German language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-dk.control b/openwrt/package/webif/ipkg/webif-lang-dk.control
new file mode 100644 (file)
index 0000000..5b76faf
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-dk
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Danish language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-ee.control b/openwrt/package/webif/ipkg/webif-lang-ee.control
new file mode 100644 (file)
index 0000000..28683b4
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-ee
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Estonian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-es.control b/openwrt/package/webif/ipkg/webif-lang-es.control
new file mode 100644 (file)
index 0000000..4108e15
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-es
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Spanish language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-fr.control b/openwrt/package/webif/ipkg/webif-lang-fr.control
new file mode 100644 (file)
index 0000000..0ac3d18
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-fr
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: French language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-hr.control b/openwrt/package/webif/ipkg/webif-lang-hr.control
new file mode 100644 (file)
index 0000000..d399723
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-hr
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Croatian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-hu.control b/openwrt/package/webif/ipkg/webif-lang-hu.control
new file mode 100644 (file)
index 0000000..6d74aa5
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-hu
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Hungarian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-it.control b/openwrt/package/webif/ipkg/webif-lang-it.control
new file mode 100644 (file)
index 0000000..13dfd59
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-it
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Italian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-nl.control b/openwrt/package/webif/ipkg/webif-lang-nl.control
new file mode 100644 (file)
index 0000000..7c4bac2
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-nl
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Dutch language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-no.control b/openwrt/package/webif/ipkg/webif-lang-no.control
new file mode 100644 (file)
index 0000000..0d17ff0
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-no
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Norwegian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-pl.control b/openwrt/package/webif/ipkg/webif-lang-pl.control
new file mode 100644 (file)
index 0000000..dcef5e8
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-pl
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Polish language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-ru.control b/openwrt/package/webif/ipkg/webif-lang-ru.control
new file mode 100644 (file)
index 0000000..3754789
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-ru
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Russian language file for webif.
+
diff --git a/openwrt/package/webif/ipkg/webif-lang-se.control b/openwrt/package/webif/ipkg/webif-lang-se.control
new file mode 100644 (file)
index 0000000..a90889a
--- /dev/null
@@ -0,0 +1,7 @@
+Package: webif-lang-se
+Maintainer: Felix Fietkau <nbd@openwrt.org>
+Section: net
+Depends: webif
+Priority: normal
+Description: Swedish language file for webif.
+