compat-wireless: make patches apply again
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 31 Aug 2011 22:10:29 +0000 (00:10 +0200)
committerLuis R. Rodriguez <mcgrof@qca.qualcomm.com>
Wed, 31 Aug 2011 22:18:10 +0000 (15:18 -0700)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
patches/09-threaded-irq.patch
patches/35-fix-makefile-includes.patch
patches/37-vsnprintk.patch

index de84972892293a859fc714c6ca4e9b0280ce433c..bea44d2459e3f36ce211540143956826e931c871 100644 (file)
@@ -6,7 +6,7 @@ thread in process context as well.
 
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -4168,8 +4168,13 @@ redo:
+@@ -4171,8 +4171,13 @@ redo:
        if (b43_bus_host_is_sdio(dev->dev)) {
                b43_sdio_free_irq(dev);
        } else {
@@ -20,7 +20,7 @@ thread in process context as well.
        }
        mutex_lock(&wl->mutex);
        dev = wl->current_dev;
-@@ -4209,9 +4214,17 @@ static int b43_wireless_core_start(struc
+@@ -4212,9 +4217,17 @@ static int b43_wireless_core_start(struc
                        goto out;
                }
        } else {
@@ -38,7 +38,7 @@ thread in process context as well.
                if (err) {
                        b43err(dev->wl, "Cannot request IRQ-%d\n",
                               dev->dev->irq);
-@@ -5000,6 +5013,10 @@ static int b43_setup_bands(struct b43_wl
+@@ -5003,6 +5016,10 @@ static int b43_setup_bands(struct b43_wl
  
  static void b43_wireless_core_detach(struct b43_wldev *dev)
  {
@@ -122,10 +122,10 @@ thread in process context as well.
        return 0;
 --- a/drivers/net/wireless/wl12xx/wl12xx.h
 +++ b/drivers/net/wireless/wl12xx/wl12xx.h
-@@ -622,6 +622,10 @@ struct wl1271 {
+@@ -623,6 +623,10 @@ struct wl1271 {
  
-       /* Platform limitations */
-       unsigned int platform_quirks;
+       /* number of currently active RX BA sessions */
+       int ba_rx_session_count;
 +
 +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
 +      struct compat_threaded_irq irq_compat;
index aa3dd92a171868f37a7a85ca87a53007f9cb7a0b..17994b74946f38da93c9af804a5ddb967cb59d12 100644 (file)
@@ -20,7 +20,7 @@ path the make process will search in the kernel tree for the headers.
 +ccflags-y += -I$(obj)/..
 --- a/drivers/staging/brcm80211/brcmfmac/Makefile
 +++ b/drivers/staging/brcm80211/brcmfmac/Makefile
-@@ -23,8 +23,8 @@ ccflags-y :=                 \
+@@ -18,8 +18,8 @@
  ccflags-$(CONFIG_BRCMDBG)     += -DSHOW_EVENTS
  
  ccflags-y += \
@@ -33,10 +33,10 @@ path the make process will search in the kernel tree for the headers.
        wl_cfg80211.o \
 --- a/drivers/staging/brcm80211/brcmsmac/Makefile
 +++ b/drivers/staging/brcm80211/brcmsmac/Makefile
-@@ -23,9 +23,9 @@ ccflags-y :=                         \
-       -DWL11N                                 \
-       -DDBAND                                 \
      -DBCMNVRAMR                             \
+@@ -16,9 +16,9 @@
+ # CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
ccflags-y :=                          \
 -      -Idrivers/staging/brcm80211/brcmsmac \
 -      -Idrivers/staging/brcm80211/brcmsmac/phy \
 -      -Idrivers/staging/brcm80211/include
index b192713b756d34a225f0f64f7b2909d325ad0b13..8217de9e1297571971f8b6748c3fbaabc487ff10 100644 (file)
@@ -1,14 +1,13 @@
 --- a/drivers/net/wireless/ath/main.c
 +++ b/drivers/net/wireless/ath/main.c
-@@ -60,16 +60,23 @@ EXPORT_SYMBOL(ath_rxbuf_alloc);
- int ath_printk(const char *level, struct ath_common *common,
             const char *fmt, ...)
+@@ -59,15 +59,22 @@ EXPORT_SYMBOL(ath_rxbuf_alloc);
void ath_printk(const char *level, const char *fmt, ...)
  {
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36))
        struct va_format vaf;
 +#endif
        va_list args;
-       int rtn;
  
        va_start(args, fmt);
  
        vaf.fmt = fmt;
        vaf.va = &args;
  
-       rtn = printk("%sath: %pV", level, &vaf);
+       printk("%sath: %pV", level, &vaf);
 +#else
 +      printk("%sath: ", level);
-+      rtn = vprintk(fmt, args);
++      vprintk(fmt, args);
 +#endif
  
        va_end(args);
+ }