projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
50d052a
)
add better working-g++ check (patch from #2017)
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 23 Jul 2007 02:56:30 +0000
(
02:56
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 23 Jul 2007 02:56:30 +0000
(
02:56
+0000)
SVN-Revision: 8118
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index 6311e601ba46410bad706961fdac380adc12d81d..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-52,7
+52,8
@@
$(eval $(call Require,working-gcc, \
define Require/working-g++
echo 'int main(int argc, char **argv) { return 0; }' | \
- g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+ g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+ $(TMP_DIR)/a.out
endef
$(eval $(call Require,working-g++, \