projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0196414
)
linux: Add kmod-crxypto-xcbc
author
Hauke Mehrtens
<hauke.mehrtens@intel.com>
Thu, 21 Mar 2019 18:16:15 +0000
(19:16 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 25 Mar 2019 21:50:28 +0000
(22:50 +0100)
This can be used for IPsec.
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index d70eb924c32030d8f0192d18ee933a810ff00fdf..1add16e161b2b1cd26dbd746f9af6f8f82a9cff8 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-226,6
+226,18
@@
endef
$(eval $(call KernelPackage,crypto-gcm))
+define KernelPackage/crypto-xcbc
+ TITLE:=XCBC CryptoAPI module
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_XCBC
+ FILES:=$(LINUX_DIR)/crypto/xcbc.ko
+ AUTOLOAD:=$(call AutoLoad,09,xcbc)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xcbc))
+
+
define KernelPackage/crypto-gf128
TITLE:=GF(2^128) multiplication functions CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_GF128MUL