config: rename SECCOMP to USE_SECCOMP
authorRobert Marko <robimarko@gmail.com>
Sat, 23 Nov 2024 13:29:49 +0000 (14:29 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 3 Jan 2025 10:18:56 +0000 (11:18 +0100)
It seems that we have some kind of a symbol name conflict which causes
CONFIG_SECCOMP to always be read as y.

Unfortunatelly, I could not figure out what is causing this, but simply
renaming SECCOMP to USE_SECCOMP seems to properly work and leaves the
symbol unset unless arch dependencies are satisfied.

This fixes qoriq and others that dont support seccomp from failing due
to procd-seccomp package being selected to get included but it cannot be
built for them:
ERROR: unable to select packages:
  procd-seccomp (no such package):
    required by: base-files-1637~52b6c92479[procd-seccomp]

Fixes: 4c65359af49b ("build: fix including busybox, procd and apk/opkg in imagebuilder")
Link: https://github.com/openwrt/openwrt/pull/17048
Signed-off-by: Robert Marko <robimarko@gmail.com>
(cherry picked from commit a48ec449ccab0069e84a72837bf06ba543e53aec)

config/Config-build.in
package/base-files/Makefile
package/system/procd/Makefile

index ae44985546b6dd092551111c6023bf50601111d0..08acae63d3b24ef6d56298be9e8bbdbb2015f09c 100644 (file)
@@ -423,7 +423,7 @@ menu "Global build settings"
 
        endchoice
 
-       config SECCOMP
+       config USE_SECCOMP
                bool "Enable SECCOMP"
                select KERNEL_SECCOMP
                select PACKAGE_procd-seccomp
index 7ac4ea557f9f10d4d13407b5e8c5cb69a40df304..c78c073699f2dc7dd1fecd6781b7fdc4121344bf 100644 (file)
@@ -42,7 +42,7 @@ define Package/base-files
   DEPENDS:= \
        +netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring \
        +NAND_SUPPORT:ubi-utils +fstools +fwtool \
-       +SELINUX:procd-selinux +!SELINUX:procd +SECCOMP:procd-seccomp \
+       +SELINUX:procd-selinux +!SELINUX:procd +USE_SECCOMP:procd-seccomp \
        +SELINUX:busybox-selinux +!SELINUX:busybox
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
index 88467c2e5922fd85318e38a3081154afc98c39b2..7a2276a46d1967f7a3662d2ee10e7403bd884e25 100644 (file)
@@ -71,7 +71,7 @@ endef
 define Package/procd-seccomp
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=@SECCOMP +libubox +libblobmsg-json
+  DEPENDS:=@USE_SECCOMP +libubox +libblobmsg-json
   TITLE:=OpenWrt process seccomp helper + utrace
 endef