elfutils: revert r35558
authorFlorian Fainelli <florian@openwrt.org>
Mon, 11 Feb 2013 17:19:37 +0000 (17:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 11 Feb 2013 17:19:37 +0000 (17:19 +0000)
libdwfl which is a libdw dependency requires argp-standalone at least.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35563

libs/elfutils/Makefile

index 0aa8d7786698dbd9e4e3a2f14c4df92072a62b0c..449e790c4c6057bf2fe974fc40e188690556f722 100644 (file)
@@ -16,6 +16,8 @@ PKG_MD5SUM:=163a5712b86f6bdfebdf233cc6e2192d
 
 PKG_INSTALL:=1
 
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
@@ -42,6 +44,11 @@ ifeq ($(CONFIG_BUILD_NLS),y)
 TARGET_LDFLAGS += "-lintl"
 endif
 
+ifdef CONFIG_USE_UCLIBC
+CONFIGURE_VARS += \
+       LIBS="-largp"
+endif
+
 CONFIGURE_ARGS += \
        --disable-werror