multiwan: Updated failover removal
authorCraig M. Coffee <cmcoffee@gmail.com>
Mon, 26 Apr 2010 18:54:10 +0000 (18:54 +0000)
committerCraig M. Coffee <cmcoffee@gmail.com>
Mon, 26 Apr 2010 18:54:10 +0000 (18:54 +0000)
SVN-Revision: 21176

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index 1bc7a9b66734f99b865cc0bf8b4df2537a3129bb..cbe867501fdead3c2eec61270bf81e3ce317169c 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
-PKG_VERSION:=1.0l
-PKG_RELEASE:=2
+PKG_VERSION:=1.0m
+PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
 
index 1d610f5962dd1da5df98aefcf74755b4ee8ddc25..5b2ba76d80befeb1ec2856ab8cbb215e48532d84 100755 (executable)
@@ -40,11 +40,7 @@ fi
 
 del() {
 if [ "$existing_failover" == "3" ]; then
-       if [ "$failover_to" != "balancer" -a "failover_to" != "disable" -a "$failover_to_wanid" != "$wanid" ]; then
-               iptables -D FW${wanid}MARK -t mangle -j FW${failover_to_wanid}MARK
-       elif [ "$failover_to" == "balancer" ]; then
-               iptables -D FW${wanid}MARK -t mangle -j LoadBalancer
-       fi
+               iptables -D FW${wanid}MARK 2 -t mangle
 fi
         mwnote "$1 has recovered and is back online!"
 }