projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
55922c9
)
kbuild: silence Nothing to be done for 'all' message
author
Peter Foley
<pefoley2@verizon.net>
Thu, 9 Jun 2011 00:58:32 +0000
(20:58 -0400)
committer
Michal Marek
<mmarek@suse.cz>
Thu, 9 Jun 2011 09:48:19 +0000
(11:48 +0200)
This patch silences a Makefile.asm-generic message
by defining a dummy rule for all.
make -f /usr/src/git/scripts/Makefile.asm-generic \
obj=arch/x86/include/generated/asm
make[1]: Nothing to be done for `all'.
Signed-off-by: Peter Foley <pefoley2@verizon.net>
Signed-off-by: Michal Marek <mmarek@suse.cz>
scripts/Makefile.asm-generic
patch
|
blob
|
history
diff --git
a/scripts/Makefile.asm-generic
b/scripts/Makefile.asm-generic
index 490122c3e2aaf4e3e7ef8580cfbe9f2033c86644..40caf3c26cd5abdb3b22493715ebba38aa691a8a 100644
(file)
--- a/
scripts/Makefile.asm-generic
+++ b/
scripts/Makefile.asm-generic
@@
-17,6
+17,7
@@
quiet_cmd_wrap = WRAP $@
cmd_wrap = echo "\#include <asm-generic/$*.h>" >$@
all: $(patsubst %, $(obj)/%, $(generic-y))
+ @:
$(obj)/%.h:
$(call cmd,wrap)