projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
64568ca
)
kernel: fix broken dependency of kmod-owl-loader on kmod-ath9k
author
Felix Fietkau
<nbd@nbd.name>
Thu, 22 Sep 2016 18:09:19 +0000
(20:09 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Thu, 22 Sep 2016 18:09:20 +0000
(20:09 +0200)
It messes up the build order of package/kernel/linux vs
package/kernel/mac80211
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index a5e0f508db58539551638c4a1bb14aca60c73616..358e83a4d4c28a3df85d8855d3b444fc64689c4e 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-1044,7
+1044,7
@@
$(eval $(call KernelPackage,bmp085-spi))
define KernelPackage/owl-loader
SUBMENU:=$(WIRELESS_MENU)
TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
- DEPENDS:=@PCI_SUPPORT
+kmod-ath9k
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:=CONFIG_OWL_LOADER
FILES:=$(LINUX_DIR)/drivers/misc/owl-loader.ko
AUTOLOAD:=$(call AutoProbe,owl-loader)