projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
979fb5a
)
improve xargs compatibility check (mostly Darwin/Mac OS X related)
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 1 Jul 2008 21:38:28 +0000
(21:38 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 1 Jul 2008 21:38:28 +0000
(21:38 +0000)
SVN-Revision: 11613
include/host.mk
patch
|
blob
|
history
diff --git
a/include/host.mk
b/include/host.mk
index 00eb1f55aafef0a1072e0dfa07b4071eaee5aa86..9d40ec40a31b2487d9316534bf3991ab3d6a47c3 100644
(file)
--- a/
include/host.mk
+++ b/
include/host.mk
@@
-39,12
+39,11
@@
$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
else \
echo 'FIND_L=find $$(1) -follow' >> $@; \
fi; \
+ if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+ echo 'XARGS:=xargs -r' >> $@; \
+ else \
+ echo 'XARGS:=xargs' >> $@; \
+ fi; \
)
endif
-
-ifeq ($(HOST_OS),Linux)
- XARGS:=xargs -r
-else
- XARGS:=xargs
-endif