build: use host cflags/ldflags for openssl prereq check
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Oct 2015 14:12:42 +0000 (14:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Oct 2015 14:12:42 +0000 (14:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r47138

SVN-Revision: 47140

include/prereq-build.mk

index 211201af3da1e0aaf85a2b3701f78c3bd0d6f499..32c4adabb748c4026d507d40769b3201e2ac5599 100644 (file)
@@ -68,7 +68,7 @@ $(eval $(call TestHostCommand,zlib, \
 $(eval $(call TestHostCommand,libssl, \
        Please install the openssl library (with development headers), \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+               gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
 
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \