compat-wireless: fix unresolved symbols with old kernels
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Sep 2010 17:49:13 +0000 (10:49 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 20 Sep 2010 15:29:53 +0000 (08:29 -0700)
CONFIG_WEXT_PRIV and CONFIG_WEXT_SPY were introduced with kernel 2.6.33
and are not available in older kernel versions. We should just depend on
them for recent kernel versions, but this feature is not implemented in
compat-wireless yet. If compat-wireless was commpield against kernel <
2.6.29 with e.g. CONFIG_IPW2200=m then libipw was not build in compat-
wireless but ipw2200 was build, because the config options set in the
kernel config were used. For now we build ipw2*00 every time
CONFIG_WIRELESS_EXT is enabled. This could cause some problems with
kernel > 2.6.32 and CONFIG_WEXT_PRIV=n but there are no such
distribution kernel available and we haven't got an bug report because
of this problem although is problem existed for a long time.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk

index 7f73744fda40e18b136d0dc40f6b2626e6a99781..de5766f9aa44dbfa80380363f89a81e8d7033e42 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -249,8 +249,6 @@ CONFIG_B43LEGACY_DMA=y
 CONFIG_B43LEGACY_PIO=y
 
 ifdef CONFIG_WIRELESS_EXT
-ifdef CONFIG_WEXT_SPY
-ifdef CONFIG_WEXT_PRIV
 # The Intel ipws
 CONFIG_LIBIPW=m
 # CONFIG_LIBIPW_DEBUG=y
@@ -276,8 +274,6 @@ CONFIG_IPW2200_QOS=y
 # it on via sysfs:
 #
 # % echo 1 > /sys/bus/pci/drivers/ipw2200/*/rtap_iface
-endif #CONFIG_WEXT_PRIV
-endif #CONFIG_WEXT_SPY
 endif #CONFIG_WIRELESS_EXT
 
 ifdef CONFIG_SSB
@@ -337,8 +333,6 @@ CONFIG_ATL1C=m
 endif #CONFIG_COMPAT_KERNEL_27
 
 ifdef CONFIG_WIRELESS_EXT
-ifdef CONFIG_WEXT_SPY
-ifdef CONFIG_WEXT_PRIV
 CONFIG_HERMES=m
 CONFIG_HERMES_CACHE_FW_ON_INIT=y
 ifdef CONFIG_PPC_PMAC
@@ -352,8 +346,6 @@ ifdef CONFIG_PCMCIA
 CONFIG_PCMCIA_HERMES=m
 CONFIG_PCMCIA_SPECTRUM=m
 endif #CONFIG_PCMCIA
-endif #CONFIG_WEXT_PRIV
-endif #CONFIG_WEXT_SPY
 endif #CONFIG_WIRELESS_EXT
 
 endif #CONFIG_PCI