uboot-rockchip: use u-boot-rockchip.bin
authorFUKAUMI Naoki <naoki@radxa.com>
Wed, 3 Jul 2024 09:02:32 +0000 (18:02 +0900)
committerRobert Marko <robimarko@gmail.com>
Thu, 4 Jul 2024 17:26:00 +0000 (19:26 +0200)
use u-boot-rockchip.bin to copy SPL/TPL/U-Boot to the image.

since binman was used in mainline u-boot for rockchip, we can use
u-boot-rockchip.bin instead of idbloader.img and u-boot.itb.

Reviewed-by: Tianling Shen <cnsztl@immortalwrt.org>
Signed-off-by: FUKAUMI Naoki <naoki@radxa.com>
Link: https://github.com/openwrt/openwrt/pull/15815
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/boot/uboot-rockchip/Makefile
target/linux/rockchip/image/Makefile

index 844f59e9f6ba9e45fab76db5e79aa1fa952fb439..7cc22cce0fe112c1c4d592f3cf6f89dbe9093713 100644 (file)
@@ -211,8 +211,7 @@ UBOOT_MAKE_FLAGS += \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
-       $(CP) $(PKG_BUILD_DIR)/idbloader.img $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-idbloader.img
-       $(CP) $(PKG_BUILD_DIR)/u-boot.itb $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot.itb
+       $(CP) $(PKG_BUILD_DIR)/u-boot-rockchip.bin $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot-rockchip.bin
 endef
 
 define Package/u-boot/install/default
index 5de053bdb6bbb9a93877bfc40fccf49aa077b491..5d90ef8cf835c642ef398e6a5d453f1cffe07090 100644 (file)
@@ -29,7 +29,7 @@ define Build/pine64-img
        # combining boot partition, root partition as well as the u-boot bootloader
 
        # Generate a new partition table in $@ with 32 MiB of 
-       # alignment padding for the idbloader and u-boot to fit:
+       # alignment padding for the u-boot-rockchip.bin (idbloader + u-boot) to fit:
        # http://opensource.rock-chips.com/wiki_Boot_option#Boot_flow
        #
        # U-Boot SPL expects the U-Boot ITB to be located at sector 0x4000 (8 MiB) on the MMC storage
@@ -39,9 +39,8 @@ define Build/pine64-img
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \
                32768
 
-       # Copy the idbloader and the u-boot image to the image at sector 0x40 and 0x4000
-       dd if="$(STAGING_DIR_IMAGE)"/$(UBOOT_DEVICE_NAME)-idbloader.img of="$@" seek=64 conv=notrunc
-       dd if="$(STAGING_DIR_IMAGE)"/$(UBOOT_DEVICE_NAME)-u-boot.itb of="$@" seek=16384 conv=notrunc
+       # Copy the u-boot-rockchip.bin to the image at sector 0x40
+       dd if="$(STAGING_DIR_IMAGE)"/$(UBOOT_DEVICE_NAME)-u-boot-rockchip.bin of="$@" seek=64 conv=notrunc
 endef
 
 ### Devices ###