[packages] openssh: if CONFIG_OPENSSL_ENGINE is defined compile with --with-ssl-engine
authorPeter Wagner <​tripolar@gmx.at>
Mon, 14 Nov 2011 00:51:20 +0000 (00:51 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Mon, 14 Nov 2011 00:51:20 +0000 (00:51 +0000)
SVN-Revision: 29087

net/openssh/Makefile

index d668be4f9d2e8e1318fdaf5010bba8810c3cbfb6..527bd98f584f662d57dea195123c0e395764c93e 100644 (file)
@@ -127,6 +127,11 @@ CONFIGURE_ARGS+= \
        --without-pam \
        --without-x
 
+ifdef CONFIG_OPENSSL_ENGINE
+CONFIGURE_ARGS+= \
+       --with-ssl-engine
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),y)
 CONFIGURE_ARGS += \
        --without-stackprotect