net: hns3: Add HNS3 driver to kernel build framework & MAINTAINERS
authorSalil <salil.mehta@huawei.com>
Wed, 2 Aug 2017 15:59:52 +0000 (16:59 +0100)
committerDavid S. Miller <davem@davemloft.net>
Thu, 3 Aug 2017 22:08:18 +0000 (15:08 -0700)
This patch updates the MAINTAINERS file with HNS3 Ethernet driver
maintainers names and other details. This also introduces the new
Makefiles required to build the HNS3 Ethernet driver and updates
the existing Kconfig file in the hisilicon folder.

Signed-off-by: Salil Mehta <salil.mehta@huawei.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
MAINTAINERS
drivers/net/ethernet/hisilicon/Kconfig
drivers/net/ethernet/hisilicon/Makefile
drivers/net/ethernet/hisilicon/hns3/Makefile [new file with mode: 0644]
drivers/net/ethernet/hisilicon/hns3/hns3pf/Makefile [new file with mode: 0644]

index c67618c97c5d53561ea70fbf2b25c83fd529b944..a515da73c7e4cecee23da164a58f563eb4f74ecb 100644 (file)
@@ -6148,6 +6148,14 @@ S:       Maintained
 F:     drivers/net/ethernet/hisilicon/
 F:     Documentation/devicetree/bindings/net/hisilicon*.txt
 
+HISILICON NETWORK SUBSYSTEM 3 DRIVER (HNS3)
+M:     Yisen Zhuang <yisen.zhuang@huawei.com>
+M:     Salil Mehta <salil.mehta@huawei.com>
+L:     netdev@vger.kernel.org
+W:     http://www.hisilicon.com
+S:     Maintained
+F:     drivers/net/ethernet/hisilicon/hns3/
+
 HISILICON ROCE DRIVER
 M:     Lijun Ou <oulijun@huawei.com>
 M:     Wei Hu(Xavier) <xavier.huwei@huawei.com>
index d11287e11371f06d1cd3d9e7860feed1934a1610..91c7bdb9b43cc88b8aabc3a4cc59f36c6db2cef4 100644 (file)
@@ -76,4 +76,31 @@ config HNS_ENET
          This selects the general ethernet driver for HNS.  This module make
          use of any HNS AE driver, such as HNS_DSAF
 
+config HNS3
+       tristate "Hisilicon Network Subsystem Support HNS3 (Framework)"
+    depends on PCI
+       ---help---
+         This selects the framework support for Hisilicon Network Subsystem 3.
+         This layer facilitates clients like ENET, RoCE and user-space ethernet
+         drivers(like ODP)to register with HNAE devices and their associated
+         operations.
+
+config HNS3_HCLGE
+       tristate "Hisilicon HNS3 HCLGE Acceleration Engine & Compatibility Layer Support"
+    depends on PCI_MSI
+       depends on HNS3
+       ---help---
+         This selects the HNS3_HCLGE network acceleration engine & its hardware
+         compatibility layer. The engine would be used in Hisilicon hip08 family of
+         SoCs and further upcoming SoCs.
+
+config HNS3_ENET
+       tristate "Hisilicon HNS3 Ethernet Device Support"
+    depends on 64BIT && PCI
+       depends on HNS3 && HNS3_HCLGE
+       ---help---
+         This selects the Ethernet Driver for Hisilicon Network Subsystem 3 for hip08
+         family of SoCs. This module depends upon HNAE3 driver to access the HNAE3
+         devices and their associated operations.
+
 endif # NET_VENDOR_HISILICON
index 8661695024dc378ee101a0ce6f2c143ea0c0a030..3828c435c18f29c7008821099adb660b5d6c725b 100644 (file)
@@ -6,4 +6,5 @@ obj-$(CONFIG_HIX5HD2_GMAC) += hix5hd2_gmac.o
 obj-$(CONFIG_HIP04_ETH) += hip04_eth.o
 obj-$(CONFIG_HNS_MDIO) += hns_mdio.o
 obj-$(CONFIG_HNS) += hns/
+obj-$(CONFIG_HNS3) += hns3/
 obj-$(CONFIG_HISI_FEMAC) += hisi_femac.o
diff --git a/drivers/net/ethernet/hisilicon/hns3/Makefile b/drivers/net/ethernet/hisilicon/hns3/Makefile
new file mode 100644 (file)
index 0000000..a9349e1
--- /dev/null
@@ -0,0 +1,7 @@
+#
+# Makefile for the HISILICON network device drivers.
+#
+
+obj-$(CONFIG_HNS3) += hns3pf/
+
+obj-$(CONFIG_HNS3) += hnae3.o
diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3pf/Makefile b/drivers/net/ethernet/hisilicon/hns3/hns3pf/Makefile
new file mode 100644 (file)
index 0000000..162e8a4
--- /dev/null
@@ -0,0 +1,11 @@
+#
+# Makefile for the HISILICON network device drivers.
+#
+
+ccflags-y := -Idrivers/net/ethernet/hisilicon/hns3
+
+obj-$(CONFIG_HNS3_HCLGE) += hclge.o
+hclge-objs = hclge_main.o hclge_cmd.o hclge_mdio.o hclge_tm.o
+
+obj-$(CONFIG_HNS3_ENET) += hns3.o
+hns3-objs = hns3_enet.o hns3_ethtool.o