Revert "build: set PATH for post-install scripts"
authorDaniel Golle <daniel@makrotopia.org>
Sat, 9 Nov 2024 13:06:02 +0000 (13:06 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 9 Nov 2024 13:43:56 +0000 (13:43 +0000)
This reverts commit 21b5ac862eed7ac373361c914cf6098cab04f503.
The approach is flawed and cannot work in the ImageBuilder.
Using /etc/uci-defaults/ which is run on the target is the only
possible way.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/rootfs.mk

index ff7fd185fe23180c4e47488e8b183875901f6931..e6cadc531df75429f8114c83984f0be8726efbda 100644 (file)
@@ -84,7 +84,7 @@ define prepare_rootfs
                        IPKG_POSTINST_PATH=./usr/lib/opkg/info/*.postinst; \
                fi; \
                for script in $$IPKG_POSTINST_PATH; do \
-                       PATH="$(TARGET_PATH_PKG)" IPKG_INSTROOT=$(1) $$(command -v bash) $$script; \
+                       IPKG_INSTROOT=$(1) $$(command -v bash) $$script; \
                        ret=$$?; \
                        if [ $$ret -ne 0 ]; then \
                                echo "postinst script $$script has failed with exit code $$ret" >&2; \