imagebuilder: cleanup package inclusion
authorPaul Spooren <mail@aparcar.org>
Wed, 6 Nov 2024 15:34:32 +0000 (16:34 +0100)
committerPaul Spooren <mail@aparcar.org>
Sat, 9 Nov 2024 15:46:41 +0000 (16:46 +0100)
Previously three different ways to include packages in an ImageBuilder
existed:

* buildbot: include libc, kernel (and base-files) in $(IB_LDIR)
* not buildbot, standalone: include all packages in ./packages/
* not buildbot, not standalone: include libc, kernel (and base-files) in
  ./packages/

First of, the separation between *buildbot* and *not buildbot, not
standalone* is not required, we can just always copy packages to
./packages instead of ever using the special place $(IB_LDIR).
Doing so drops the need to handle the extra case and also allows to
clean up the OPKG package installation, which no longer requries the
`firstword` logic, things are now always at ./packages.

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/imagebuilder/Makefile
target/imagebuilder/files/Makefile

index d455cbcd7aa303fda62d64d2ef32485499381d63..19f21472bdc2756e8fb15d3a9efded0ea6b30891 100644 (file)
@@ -68,25 +68,16 @@ else
        echo 'src imagebuilder file:packages'                          >> $(PKG_BUILD_DIR)/repositories.conf
 endif
 
-ifeq ($(CONFIG_BUILDBOT),)
-  ifeq ($(CONFIG_IB_STANDALONE),)
+ifeq ($(CONFIG_IB_STANDALONE),)
        $(FIND) $(call FeedPackageDir,libc) -type f \
          \( \
                -name 'base-files-*.$(PACKAGE_SUFFIX)' -or \
                -name 'libc-*.$(PACKAGE_SUFFIX)' -or \
                -name 'kernel-*.$(PACKAGE_SUFFIX)' \) \
          -exec $(CP) -t $(PKG_BUILD_DIR)/packages {} +
-  else
+else
        $(FIND) $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.$(PACKAGE_SUFFIX)' \
                -exec $(CP) -t $(PKG_BUILD_DIR)/packages/ {} +
-  endif
-else
-       $(FIND) $(call FeedPackageDir,libc) -type f \
-               \( \
-                 -name 'base-files-*.$(PACKAGE_SUFFIX)' -or \
-                 -name 'libc-*.$(PACKAGE_SUFFIX)' -or \
-                 -name 'kernel-*.$(PACKAGE_SUFFIX)' \) \
-               -exec $(CP) -t $(IB_LDIR)/ {} +
 endif
 
 ifneq ($(CONFIG_SIGNATURE_CHECK),)
index 1ac05baa50b8f1805e8633f28dac2b55abfd2bdc..914609ada15f6a2bbecf277dd4d97cc5153a5ca8 100644 (file)
@@ -222,8 +222,8 @@ package_install: FORCE
        @echo
        @echo Installing packages...
 ifeq ($(CONFIG_USE_APK),)
-       $(OPKG) install $(firstword $(wildcard $(LINUX_DIR)/libc_*.ipk $(PACKAGE_DIR)/libc_*.ipk))
-       $(OPKG) install $(firstword $(wildcard $(LINUX_DIR)/kernel_*.ipk $(PACKAGE_DIR)/kernel_*.ipk))
+       $(OPKG) install $(wildcard $(PACKAGE_DIR)/libc_*.ipk)
+       $(OPKG) install $(wildcard $(PACKAGE_DIR)/kernel_*.ipk)
        $(OPKG) install $(BUILD_PACKAGES)
 else
        $(APK) add --no-scripts $(BUILD_PACKAGES)