ipq40xx: Select correct board-2.bin for EnGenius EMD1
authorSven Eckelmann <sven@narfation.org>
Sat, 11 Sep 2021 06:33:30 +0000 (08:33 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 19 Sep 2021 18:00:50 +0000 (20:00 +0200)
The board data file for the EnGenius EMD1 is not part of the default
board-2.bin which is shipped by ath10k-board-qca4019. As result, the wrong
calibration information will be loaded into the wifi chip.

Fixes: 51f303597839 ("ipq40xx: add support for EnGenius EMD1")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
(cherry picked from commit d9f4a4280e674ddb4ec75ae2d73b0f86e0c282cc)

target/linux/ipq40xx/image/generic.mk

index a435a127fade6dee74f772e9b7726e1325161f72..6f88e3178a3e9442bfba1fc3f9310ddcc75b9e37 100644 (file)
@@ -409,6 +409,7 @@ define Device/engenius_emd1
        IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       DEVICE_PACKAGES := ipq-wifi-engenius_emd1
 endef
 TARGET_DEVICES += engenius_emd1