ifeq ($(LINUX_VERSION),2.6.24.7)
LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
endif
-ifeq ($(LINUX_VERSION),2.6.25.12)
- LINUX_KERNEL_MD5SUM:=7c413ecf94a84776aaec6ada5694318c
+ifeq ($(LINUX_VERSION),2.6.25.15)
+ LINUX_KERNEL_MD5SUM:=13ed94f02fc2a11615e3332e1cdf50e7
endif
-ifeq ($(LINUX_VERSION),2.6.26)
- LINUX_KERNEL_MD5SUM:=5169d01c405bc3f866c59338e217968c
+ifeq ($(LINUX_VERSION),2.6.26.2)
+ LINUX_KERNEL_MD5SUM:=82472622bd26bed0054790ec3e60ee00
endif
# disable the md5sum check for unknown kernel versions
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.12
-LINUX_VERSION:=2.6.26
+#LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.26.2
SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:=
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Atheros AR71xx
FEATURES:=squashfs tgz broken
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Atmel AT91
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Atheros 231x/5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM963xx
FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
---- linux-2.6.25.12/drivers/usb/class/cdc-acm.c 2008-07-24 18:14:20.000000000 +0200
-+++ linux-2.6.25.12.new/drivers/usb/class/cdc-acm.c 2008-08-05 21:39:35.000000000 +0200
+--- a/drivers/usb/class/cdc-acm.c
++++ b/drivers/usb/class/cdc-acm.c
@@ -531,8 +531,8 @@
tasklet_schedule(&acm->urb_task);
-Index: linux-2.6.26/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Kconfig 2008-08-04 15:03:44.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Kconfig 2008-08-04 15:04:18.000000000 +0200
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
@@ -200,4 +200,11 @@
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+ If unsure, say Y.
+
endif # NEW_LEDS
-Index: linux-2.6.26/drivers/leds/Makefile
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Makefile 2008-08-04 15:03:40.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
@@ -29,3 +29,4 @@
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
static int debug;
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; /* initially all NULL */
static DEFINE_MUTEX(table_lock);
-@@ -812,7 +813,7 @@
+@@ -815,7 +816,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1226,3 +1227,5 @@
+@@ -1229,3 +1230,5 @@
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
BOARD:=ifxmips
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES:=uboot-ifxmips
FEATURES:=squashfs
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Magicbox
FEATURES:=squashfs pci
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Marvell Orion
FEATURES:=squashfs
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
include $(INCLUDE_DIR)/target.mk
BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
KERNEL_CC:=
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 ext2 vdi
SUBTARGETS=generic
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci