projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5e41c1d
)
image: fix build issue with per-device rootfs and legacy devices
author
Felix Fietkau
<nbd@nbd.name>
Sun, 31 Jul 2016 10:38:01 +0000
(12:38 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sun, 31 Jul 2016 10:45:18 +0000
(12:45 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image-legacy.mk
patch
|
blob
|
history
diff --git
a/include/image-legacy.mk
b/include/image-legacy.mk
index 9633500fd91b02592a13f379b97d07f3ed3a63c1..9960caba0c50ed7025447e896a053aece6ae0758 100644
(file)
--- a/
include/image-legacy.mk
+++ b/
include/image-legacy.mk
@@
-65,7
+65,7
@@
define LegacyDevice/Build
ifndef IB
ifdef CONFIG_TARGET_PER_DEVICE_ROOTFS
ROOTFS/$(1) := $(foreach fs,$(TARGET_FILESYSTEMS), \
- $(KDIR)/root.$(fs)$$(strip $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),+pkg=$$(ROOTFS_ID/$(1))))
+ $(KDIR)/root.$(fs)$$(strip $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),+pkg=$$(ROOTFS_ID/$(1))))
\
)
$$(ROOTFS/$(1)): target-dir-$$(ROOTFS_ID/$(1))