projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5b392c7
)
build: image: set default parameter for check-size
author
Sungbo Eo
<mans0n@gorani.run>
Tue, 10 Mar 2020 13:58:00 +0000
(22:58 +0900)
committer
Adrian Schmutzler
<freifunk@adrianschmutzler.de>
Sat, 21 Mar 2020 18:59:08 +0000
(19:59 +0100)
In most cases check-size is used with IMAGE_SIZE and vice versa. Let check-size
use IMAGE_SIZE by default.
Signed-off-by: Sungbo Eo <mans0n@gorani.run>
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index 2ec1922044d206e45aaed2beb19ffdbb83bddd6d..e7db7128b4cac775ca424c96bebf1405db6937b4 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-269,7
+269,7
@@
define Build/xor-image
endef
define Build/check-size
- @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(
1
))))) -ge "$$(stat -c%s $@)" ] || { \
+ @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(
if $(1),$(1),$(IMAGE_SIZE)
))))) -ge "$$(stat -c%s $@)" ] || { \
echo "WARNING: Image file $@ is too big" >&2; \
rm -f $@; \
}