l7-protocols: pass our CFLAGS and CXXFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Tue, 11 Mar 2014 04:30:20 +0000 (04:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 11 Mar 2014 04:30:20 +0000 (04:30 +0000)
All the testing utilities were not using our CFLAGS or CXXFLAGS fix
that.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39867

net/l7-protocols/Makefile
net/l7-protocols/patches/100-testing_crosscompile.patch

index 6f7acf749f3b16c9d411c721852a757b5b912552..ff095cb188435479fe3708555f4681837954c035 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=l7-protocols
 PKG_VERSION:=2009-05-28
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/l7-filter
@@ -42,7 +42,7 @@ endef
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_l7-protocols-testing),)
   define Build/Compile
-       cd $(PKG_BUILD_DIR)/testing && $(MAKE) $(TARGET_CONFIGURE_OPTS)
+       cd $(PKG_BUILD_DIR)/testing && $(MAKE) $(CONFIGURE_VARS)
   endef
 else
   define Build/Compile
index 70ee2d11e042204dfd28f5f6e8958caaf295715a..b5d395307011deda92266119f0a488dc812e402a 100644 (file)
@@ -5,23 +5,23 @@
  
  randchars: randchars.c
 -      gcc -O2 -o randchars randchars.c
-+      $(CC) -O2 -o randchars randchars.c
++      $(CC) $(CFLAGS) -o randchars randchars.c
  
  randprintable: randprintable.c
 -      gcc -O2 -o randprintable randprintable.c
-+      $(CC) -O2 -o randprintable randprintable.c
++      $(CC) $(CFLAGS) -o randprintable randprintable.c
  
  test_speed-kernel: test_speed-kernel.c
 -      gcc -o test_speed-kernel test_speed-kernel.c
-+      $(CC) -o test_speed-kernel test_speed-kernel.c
++      $(CC) $(CFLAGS) -o test_speed-kernel test_speed-kernel.c
  
  test_speed-userspace: test_speed-userspace.cpp l7-parse-patterns.cpp l7-parse-patterns.h
 -      g++ -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
-+      $(CXX) -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
++      $(CXX) $(CXXFLAGS) -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
  
  match_kernel: match-kernel.c
 -      gcc -O2 -o match_kernel match-kernel.c
-+      $(CC) -O2 -o match_kernel match-kernel.c
++      $(CC) $(CFLAGS) -o match_kernel match-kernel.c
  
  clean:
        rm -f randprintable randchars test_speed-kernel test_speed-userspace match_kernel