gcc: add multilib m4/m4-nofpu config for sh4
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 30 Jan 2022 12:47:12 +0000 (13:47 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 5 Jan 2023 07:45:14 +0000 (08:45 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
toolchain/gcc/common.mk

index 6661b0aa38dfc73f041a1f9490395991370237e1..c9653f06c970050c8ca0bb8c7a74b9c8d9e35947 100644 (file)
@@ -77,6 +77,10 @@ else
   GRAPHITE_CONFIGURE:= --without-isl --without-cloog
 endif
 
+ifneq ($(CONFIG_sh4),y)
+       DISABLE_MULTILIB:=--disable-multilib
+endif
+
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
@@ -140,6 +144,11 @@ ifdef CONFIG_sparc
                --with-long-double-128
 endif
 
+ifdef CONFIG_sh4
+  GCC_CONFIGURE+= \
+       --with-multilib-list=m4,m4-nofpu
+endif
+
 ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif