projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f584307
)
strace: fix build error on riscv64
author
Zoltan HERPAI
<wigyori@uid0.hu>
Wed, 15 May 2019 15:22:31 +0000
(17:22 +0200)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Sun, 8 Dec 2019 22:38:41 +0000
(23:38 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/devel/strace/Makefile
patch
|
blob
|
history
diff --git
a/package/devel/strace/Makefile
b/package/devel/strace/Makefile
index 950dafc5d9910147e85dfb3e14073425f08fc7ee..c654d91e55ea2d65544c1726b8d13eb0d2ebe5b2 100644
(file)
--- a/
package/devel/strace/Makefile
+++ b/
package/devel/strace/Makefile
@@
-36,6
+36,10
@@
ifeq ($(ARCH),aarch64)
CONFIGURE_ARGS += --enable-mpers=check
endif
+ifeq ($(ARCH),riscv64)
+ CONFIGURE_ARGS += --enable-mpers=check
+endif
+
CONFIGURE_VARS+= \
LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \