Add kid (#2235)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 09:59:41 +0000 (09:59 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 09:59:41 +0000 (09:59 +0000)
SVN-Revision: 8515

lang/kid/Makefile [new file with mode: 0644]
lang/kid/patches/000-setup.patch [new file with mode: 0644]

diff --git a/lang/kid/Makefile b/lang/kid/Makefile
new file mode 100644 (file)
index 0000000..bf12535
--- /dev/null
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kid
+PKG_VERSION:=0.9.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
+PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kid
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Kid
+ DEPENDS:=+python
+ DESCRIPTION:=\
+  Kid is a simple template language for XML based vocabularies written in Python.
+ URL=http://www.kid-templating.org/
+endef
+
+define Build/Compile
+       cd $(PKG_BUILD_DIR); \
+       CFLAGS='-I$(STAGING_DIR)/usr/include' \
+       LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
+       $(STAGING_DIR)/usr/bin/hostpython ./setup.py install \
+       --prefix=$(PKG_INSTALL_DIR)/usr
+endef
+
+define Package/kid/install
+       $(CP) -R $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,kid))
diff --git a/lang/kid/patches/000-setup.patch b/lang/kid/patches/000-setup.patch
new file mode 100644 (file)
index 0000000..aeb059e
--- /dev/null
@@ -0,0 +1,20 @@
+diff -urN kid-0.9.6_orig/setup.py kid-0.9.6/setup.py
+--- kid-0.9.6/setup.py 2007-07-16 13:02:49.000000000 +0200
++++ kid-0.9.6/setup.py 2007-08-15 14:39:37.000000000 +0200
+@@ -1,15 +1,12 @@
+ #!/usr/bin/env python
+ # bootstrap setuptools if necessary
+-from ez_setup import use_setuptools
+-use_setuptools()
++from distutils.core import setup
+ import os
+ execfile(os.path.join("kid", "release.py"))
+-from setuptools import setup, find_packages
+-
+ setup(
+     name="kid",
+     version=version,