projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4faa1ab
)
disable stdin unless make V=99; fixes bug where compilation can stall waiting for...
author
Mike Baker
<mbm@openwrt.org>
Thu, 4 Feb 2010 04:43:17 +0000
(
04:43
+0000)
committer
Mike Baker
<mbm@openwrt.org>
Thu, 4 Feb 2010 04:43:17 +0000
(
04:43
+0000)
SVN-Revision: 19511
include/verbose.mk
patch
|
blob
|
history
diff --git
a/include/verbose.mk
b/include/verbose.mk
index f795e28045b0c60084a26b83692fe7707ecfaf73..857be24a32e44c9e44c3c759dce7ca881a7eaca2 100644
(file)
--- a/
include/verbose.mk
+++ b/
include/verbose.mk
@@
-44,7
+44,7
@@
ifneq ($(KBUILD_VERBOSE),99)
SILENT:=
endif
export QUIET:=1
- SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
+ SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$*
< /dev/null
|| { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
endif
.SILENT: $(MAKECMDGOALS)