projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1985e88
)
ipq806x: fix imagebuilder
author
John Crispin
<john@openwrt.org>
Fri, 29 May 2015 11:28:44 +0000
(11:28 +0000)
committer
John Crispin
<john@openwrt.org>
Fri, 29 May 2015 11:28:44 +0000
(11:28 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45823
target/linux/ipq806x/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ipq806x/image/Makefile
b/target/linux/ipq806x/image/Makefile
index e2346e63198a3a16aba7108dcbf068f8926e7511..db5bf0acbc43139c0cbfed6e839d8256c880a93d 100644
(file)
--- a/
target/linux/ipq806x/image/Makefile
+++ b/
target/linux/ipq806x/image/Makefile
@@
-19,8
+19,12
@@
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
+define Image/Prepare
+ $(CP) $(LINUX_DIR)/vmlinux $(KDIR)/$(IMG_PREFIX)-vmlinux.elf
+endef
+
define Image/BuildKernel
- $(CP) $(
LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ $(CP) $(
KDIR)/$(IMG_PREFIX)-vmlinux.elf $(BIN_DIR)
$(call Image/BuildKernel/FIT,qcom-ipq8064-ap148)
$(call Image/BuildKernel/FIT,qcom-ipq8064-db149)
endef