qualcommax: ipq807x: define configuration for Linksys MX4x00 devices
authorPaweł Owoc <frut3k7@gmail.com>
Sat, 27 Jul 2024 21:25:14 +0000 (23:25 +0200)
committerRobert Marko <robimarko@gmail.com>
Sun, 16 Feb 2025 12:03:22 +0000 (13:03 +0100)
Define shared configuration for Linksys MX4x00 devices.

Signed-off-by: Paweł Owoc <frut3k7@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16070
(cherry picked from commit 73fc1e0aa2d9956561915e342d098a6881ec85a3)
Signed-off-by: Rafal Boni <rafal.boni@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/17889
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk

index 8ca370f57e686a1ef3f1e68efbedce77d00be686..c42393eb794ab6809842fe9e25a92169064250e1 100644 (file)
@@ -170,12 +170,17 @@ define Device/linksys_mx
        DEVICE_PACKAGES := kmod-leds-pca963x
 endef
 
-define Device/linksys_mx4200v1
+define Device/linksys_mx4x00
        $(call Device/linksys_mx)
+       SOC := ipq8174
+       DEVICE_PACKAGES += ipq-wifi-linksys_mx4200
+endef
+
+define Device/linksys_mx4200v1
+       $(call Device/linksys_mx4x00)
        DEVICE_MODEL := MX4200
        DEVICE_VARIANT := v1
-       SOC := ipq8174
-       DEVICE_PACKAGES += ipq-wifi-linksys_mx4200 kmod-bluetooth
+       DEVICE_PACKAGES += kmod-bluetooth
 endef
 TARGET_DEVICES += linksys_mx4200v1