ARM: riscpc: move RiscPC assembly files from arch/arm/lib to mach-rpc
authorRussell King <rmk+kernel@armlinux.org.uk>
Tue, 21 May 2019 14:31:42 +0000 (15:31 +0100)
committerRussell King <rmk+kernel@armlinux.org.uk>
Tue, 11 Jun 2019 16:42:36 +0000 (17:42 +0100)
Move the assembly files for RiscPC from arch/arm/lib to mach-rpc so
that we contain RiscPC bits in one subdirectory.

Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
MAINTAINERS
arch/arm/lib/Makefile
arch/arm/lib/ecard.S [deleted file]
arch/arm/lib/floppydma.S [deleted file]
arch/arm/lib/io-acorn.S [deleted file]
arch/arm/mach-rpc/Makefile
arch/arm/mach-rpc/ecard-loader.S [new file with mode: 0644]
arch/arm/mach-rpc/floppydma.S [new file with mode: 0644]
arch/arm/mach-rpc/io-acorn.S [new file with mode: 0644]

index 2c2fce72e694f6ccc2000974e9cba4f6fcafbf48..e1ff69fd5bb79036c5d983823f57a2bf665f9fef 100644 (file)
@@ -1183,7 +1183,7 @@ F:        Documentation/gpu/afbc.rst
 ARM MFM AND FLOPPY DRIVERS
 M:     Ian Molton <spyro@f2s.com>
 S:     Maintained
-F:     arch/arm/lib/floppydma.S
+F:     arch/arm/mach-rpc/floppydma.S
 F:     arch/arm/include/asm/floppy.h
 
 ARM PMU PROFILING AND DEBUGGING
index 0bff0176db2c4f1bb31dd9cdaa3b0eceaa26dcd9..b25c54585048ccc07026ded3c520d0c994832b7b 100644 (file)
@@ -31,7 +31,6 @@ else
 endif
 
 ifeq ($(CONFIG_ARCH_RPC),y)
-  lib-y                                += ecard.o io-acorn.o floppydma.o
   AFLAGS_delay-loop.o          += -march=armv4
 endif
 
diff --git a/arch/arm/lib/ecard.S b/arch/arm/lib/ecard.S
deleted file mode 100644 (file)
index e6057fa..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-/*
- *  linux/arch/arm/lib/ecard.S
- *
- *  Copyright (C) 1995, 1996 Russell King
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- * 27/03/03 Ian Molton Clean up CONFIG_CPU
- *
- */
-#include <linux/linkage.h>
-#include <asm/assembler.h>
-
-#define CPSR2SPSR(rt) \
-               mrs     rt, cpsr; \
-               msr     spsr_cxsf, rt
-
-@ Purpose: call an expansion card loader to read bytes.
-@ Proto  : char read_loader(int offset, char *card_base, char *loader);
-@ Returns: byte read
-
-ENTRY(ecard_loader_read)
-               stmfd   sp!, {r4 - r12, lr}
-               mov     r11, r1
-               mov     r1, r0
-               CPSR2SPSR(r0)
-               mov     lr, pc
-               mov     pc, r2
-               ldmfd   sp!, {r4 - r12, pc}
-
-@ Purpose: call an expansion card loader to reset the card
-@ Proto  : void read_loader(int card_base, char *loader);
-@ Returns: byte read
-
-ENTRY(ecard_loader_reset)
-               stmfd   sp!, {r4 - r12, lr}
-               mov     r11, r0
-               CPSR2SPSR(r0)
-               mov     lr, pc
-               add     pc, r1, #8
-               ldmfd   sp!, {r4 - r12, pc}
-
diff --git a/arch/arm/lib/floppydma.S b/arch/arm/lib/floppydma.S
deleted file mode 100644 (file)
index de68d3b..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-/*
- *  linux/arch/arm/lib/floppydma.S
- *
- *  Copyright (C) 1995, 1996 Russell King
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- */
-#include <linux/linkage.h>
-#include <asm/assembler.h>
-               .text
-
-               .global floppy_fiqin_end
-ENTRY(floppy_fiqin_start)
-               subs    r9, r9, #1
-               ldrbgt  r12, [r11, #-4]
-               ldrble  r12, [r11], #0
-               strb    r12, [r10], #1
-               subs    pc, lr, #4
-floppy_fiqin_end:
-
-               .global floppy_fiqout_end
-ENTRY(floppy_fiqout_start)
-               subs    r9, r9, #1
-               ldrbge  r12, [r10], #1
-               movlt   r12, #0
-               strble  r12, [r11], #0
-               subsle  pc, lr, #4
-               strb    r12, [r11, #-4]
-               subs    pc, lr, #4
-floppy_fiqout_end:
diff --git a/arch/arm/lib/io-acorn.S b/arch/arm/lib/io-acorn.S
deleted file mode 100644 (file)
index 69719ba..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-/*
- *  linux/arch/arm/lib/io-acorn.S
- *
- *  Copyright (C) 1995, 1996 Russell King
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- * 27/03/03 Ian Molton Clean up CONFIG_CPU
- *
- */
-#include <linux/linkage.h>
-#include <linux/kern_levels.h>
-#include <asm/assembler.h>
-
-               .text
-               .align
-
-.Liosl_warning:
-               .ascii  KERN_WARNING "insl/outsl not implemented, called from %08lX\0"
-               .align
-
-/*
- * These make no sense on Acorn machines.
- * Print a warning message.
- */
-ENTRY(insl)
-ENTRY(outsl)
-               adr     r0, .Liosl_warning
-               mov     r1, lr
-               b       printk
index 2ebc6875aeb8f69dc4e27fd1bc3f636e8b2125f2..ab964a66ea2aaa0801b4274cb46cee98223f497e 100644 (file)
@@ -4,4 +4,5 @@
 
 # Object file lists.
 
-obj-y                  := dma.o ecard.o fiq.o irq.o riscpc.o time.o
+obj-y  :=dma.o ecard.o ecard-loader.o fiq.o floppydma.o io-acorn.o irq.o \
+         riscpc.o time.o
diff --git a/arch/arm/mach-rpc/ecard-loader.S b/arch/arm/mach-rpc/ecard-loader.S
new file mode 100644 (file)
index 0000000..e6057fa
--- /dev/null
@@ -0,0 +1,44 @@
+/*
+ *  linux/arch/arm/lib/ecard.S
+ *
+ *  Copyright (C) 1995, 1996 Russell King
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ * 27/03/03 Ian Molton Clean up CONFIG_CPU
+ *
+ */
+#include <linux/linkage.h>
+#include <asm/assembler.h>
+
+#define CPSR2SPSR(rt) \
+               mrs     rt, cpsr; \
+               msr     spsr_cxsf, rt
+
+@ Purpose: call an expansion card loader to read bytes.
+@ Proto  : char read_loader(int offset, char *card_base, char *loader);
+@ Returns: byte read
+
+ENTRY(ecard_loader_read)
+               stmfd   sp!, {r4 - r12, lr}
+               mov     r11, r1
+               mov     r1, r0
+               CPSR2SPSR(r0)
+               mov     lr, pc
+               mov     pc, r2
+               ldmfd   sp!, {r4 - r12, pc}
+
+@ Purpose: call an expansion card loader to reset the card
+@ Proto  : void read_loader(int card_base, char *loader);
+@ Returns: byte read
+
+ENTRY(ecard_loader_reset)
+               stmfd   sp!, {r4 - r12, lr}
+               mov     r11, r0
+               CPSR2SPSR(r0)
+               mov     lr, pc
+               add     pc, r1, #8
+               ldmfd   sp!, {r4 - r12, pc}
+
diff --git a/arch/arm/mach-rpc/floppydma.S b/arch/arm/mach-rpc/floppydma.S
new file mode 100644 (file)
index 0000000..de68d3b
--- /dev/null
@@ -0,0 +1,32 @@
+/*
+ *  linux/arch/arm/lib/floppydma.S
+ *
+ *  Copyright (C) 1995, 1996 Russell King
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ */
+#include <linux/linkage.h>
+#include <asm/assembler.h>
+               .text
+
+               .global floppy_fiqin_end
+ENTRY(floppy_fiqin_start)
+               subs    r9, r9, #1
+               ldrbgt  r12, [r11, #-4]
+               ldrble  r12, [r11], #0
+               strb    r12, [r10], #1
+               subs    pc, lr, #4
+floppy_fiqin_end:
+
+               .global floppy_fiqout_end
+ENTRY(floppy_fiqout_start)
+               subs    r9, r9, #1
+               ldrbge  r12, [r10], #1
+               movlt   r12, #0
+               strble  r12, [r11], #0
+               subsle  pc, lr, #4
+               strb    r12, [r11, #-4]
+               subs    pc, lr, #4
+floppy_fiqout_end:
diff --git a/arch/arm/mach-rpc/io-acorn.S b/arch/arm/mach-rpc/io-acorn.S
new file mode 100644 (file)
index 0000000..69719ba
--- /dev/null
@@ -0,0 +1,32 @@
+/*
+ *  linux/arch/arm/lib/io-acorn.S
+ *
+ *  Copyright (C) 1995, 1996 Russell King
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ * 27/03/03 Ian Molton Clean up CONFIG_CPU
+ *
+ */
+#include <linux/linkage.h>
+#include <linux/kern_levels.h>
+#include <asm/assembler.h>
+
+               .text
+               .align
+
+.Liosl_warning:
+               .ascii  KERN_WARNING "insl/outsl not implemented, called from %08lX\0"
+               .align
+
+/*
+ * These make no sense on Acorn machines.
+ * Print a warning message.
+ */
+ENTRY(insl)
+ENTRY(outsl)
+               adr     r0, .Liosl_warning
+               mov     r1, lr
+               b       printk