modules: add support for H5 (3-wire) Bluetooth UART protocols
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 24 Mar 2024 22:04:14 +0000 (23:04 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 16 Feb 2025 21:20:27 +0000 (22:20 +0100)
Most of the Realtek bluetooth devices work with the H5 (3-wire)
UART protocols. Add support for these in the hci_uart module.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/other.mk
target/linux/generic/config-6.6

index 7b64985fd69e7df95d2f19822cb3c8e4106dd267..6e950c8fc263ac9b0972617b2f687dffac13d9ff 100644 (file)
@@ -47,6 +47,7 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIUART_INTEL=n \
        CONFIG_BT_HCIUART_H4 \
        CONFIG_BT_HCIUART_NOKIA=n \
+       CONFIG_BT_HCIUART_RTL \
        CONFIG_BT_HIDP
   $(call AddDepends/rfkill)
   FILES:= \
index fe70da2d144290884c7a46c9989ccbd5ae23edab..ca639ff3ecf42c60bd419aa20e58aa922f938c04 100644 (file)
@@ -755,7 +755,7 @@ CONFIG_BT_HCIBTUSB_POLL_SYNC=y
 # CONFIG_BT_HCIBTUSB_RTL is not set
 # CONFIG_BT_HCIDTL1 is not set
 # CONFIG_BT_HCIUART is not set
-# CONFIG_BT_HCIUART_3WIRE is not set
+CONFIG_BT_HCIUART_3WIRE=y
 # CONFIG_BT_HCIUART_AG6XX is not set
 # CONFIG_BT_HCIUART_ATH3K is not set
 CONFIG_BT_HCIUART_BCSP=y
@@ -763,7 +763,7 @@ CONFIG_BT_HCIUART_H4=y
 # CONFIG_BT_HCIUART_LL is not set
 # CONFIG_BT_HCIUART_MRVL is not set
 # CONFIG_BT_HCIUART_QCA is not set
-# CONFIG_BT_HCIUART_RTL is not set
+CONFIG_BT_HCIUART_RTL=y
 # CONFIG_BT_HCIVHCI is not set
 # CONFIG_BT_HIDP is not set
 # CONFIG_BT_LE is not set