ramips: Fix EX400 imagebuilder
authorMauri Sandberg <maukka@ext.kapsi.fi>
Fri, 11 Oct 2024 07:38:07 +0000 (10:38 +0300)
committerRobert Marko <robimarko@gmail.com>
Mon, 4 Nov 2024 10:25:36 +0000 (11:25 +0100)
A factory image for DNA EX400 depends on an initramfs image and they
were explicitly removed from the imagebuilder recently. Now the factory
image creation fails miserably and it also affects custom image creation
with the firmware selector.

Add the initramfs kernel to the staging so that it's shipped with the
imagebuilder. Also remove a image build target added solely for DNA EX400.

Tested by creating a factory and syspupgrade images locally with
the imagebuilder and verified their functionality.

Related work
  c85348d9abf4 ("imagebuilder: remove initramfs image files")

Fixes: fea2264d9fdd ("ramips: mt7621: Add DNA Valokuitu Plus EX400")
Signed-off-by: Mauri Sandberg <maukka@ext.kapsi.fi>
---
v4: use append-image-stage, remove Build/kernel-initramfs-bin
v3: adjust commit subject
v2: remove fix for inconsistent line ending elsewhere in the file
Link: https://github.com/openwrt/openwrt/pull/16659
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ramips/image/mt7621.mk

index 34ed9a4d54a634cea397b12d6b477d348ca70ea4..9654e237a8af227399a2fe7a7e380ee6e5855ab3 100644 (file)
@@ -180,10 +180,6 @@ define Build/iodata-mstc-header2
        mv $@.new $@
 endef
 
-define Build/kernel-initramfs-bin
-       $(CP) $(KDIR)/vmlinux-initramfs $@
-endef
-
 define Build/znet-header
        $(eval version=$(word 1,$(1)))
        $(eval magic=$(if $(word 2,$(1)),$(word 2,$(1)),ZNET))
@@ -1093,8 +1089,8 @@ define Device/dna_valokuitu-plus-ex400
   DEVICE_MODEL := Valokuitu Plus EX400
   KERNEL := kernel-bin | lzma | uImage lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
-  IMAGES := factory.bin sysupgrade.bin
-  IMAGE/factory.bin := kernel-initramfs-bin | lzma | uImage lzma | \
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-image-stage initramfs-kernel.bin | \
                        dna-bootfs with-initrd | dna-header | \
                        append-md5sum-ascii-salted
   IMAGE/sysupgrade.bin := dna-bootfs | sysupgrade-tar kernel=$$$$@ | check-size | \