projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d9259b2
)
openssl: fix bad chmod in install section (#5433)
author
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 29 Jun 2009 20:48:58 +0000
(20:48 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 29 Jun 2009 20:48:58 +0000
(20:48 +0000)
SVN-Revision: 16624
package/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/openssl/Makefile
b/package/openssl/Makefile
index 3483c609d26cf451a05c82af48ee75387049c465..e6788172d19158d5084d83fe71cf9d6a36056179 100644
(file)
--- a/
package/openssl/Makefile
+++ b/
package/openssl/Makefile
@@
-130,8
+130,8
@@
endef
define Package/libopenssl/install
$(INSTALL_DIR) $(1)/usr/lib
- $(
CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}
.so.* $(1)/usr/lib/
- chmod 0644 $(1)/usr/lib/*
+ $(
INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto
.so.* $(1)/usr/lib/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
endef
define Package/openssl-util/install