try to add json
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 4 Mar 2019 00:25:59 +0000 (01:25 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 4 Mar 2019 00:25:59 +0000 (01:25 +0100)
include/image.mk

index 5268f0bdb7850508dcfa88a39dd54fba4fc28209..0818953ccb1fb13208b3cbe1964ef0e0d1d492ef 100644 (file)
@@ -520,7 +520,7 @@ define Device/Build/image
 
   $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
        cp $$^ $$@
-
+       echo '{ "board": "$3", "type": "$2", "image": "$(call IMAGE_NAME,$(1),$(2))" }' > $$@.json
 endef
 
 define Device/Build/artifact