sunxi: add support for Merrii Hummingbird A31
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 18 Feb 2025 17:57:53 +0000 (18:57 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 18 Feb 2025 21:50:16 +0000 (22:50 +0100)
Specifications:
 - SoC: Allwinner A31 @ 1GHz
 - DRAM: 1/2Gb DDR3
 - SD-card slot
 - NAND: 8/16Gb MLC
 - Ethernet: 1x 10/100/1000Mbps (RTL8211E)
 - Wireless: Ampak AP6210 (BCM43362)
 - 2x USB2.0
 - 1x mPCIe slot for 4G cards
 - 1x SIM slot
 - HDMI/VGA via simplefb
 - RTC with battery
 - Power via DC12V / 3A

Installation:
Use the standard sunxi installation to an SD-card. NAND is
not supported.

This is to re-add proper support for an older device.

Link: https://openwrt.org/toh/merrii/hummingbird
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortexa7.mk

index e32718a5d33ae32d9f3d178417c0d301dd5bafdf..5531de27940d257f5e4298403479ec90a20be121 100644 (file)
@@ -113,6 +113,7 @@ endef
 define U-Boot/Hummingbird_A31
   BUILD_SUBTARGET:=cortexa7
   NAME:=Hummingbird A31 board
+  BUILD_DEVICES:=merrii_hummingbird
 endef
 
 define U-Boot/Marsboard_A10
index e2d83fa94f24b9800205ee44ec6093f4d9356003..1637cd5d20d86b7f67b7a5679f2abfd6dfe6c81a 100644 (file)
@@ -145,6 +145,14 @@ define Device/mele_m9
 endef
 TARGET_DEVICES += mele_m9
 
+define Device/merrii_hummingbird
+  DEVICE_VENDOR := Merrii
+  DEVICE_MODEL := Hummingbird
+  DEVICE_PACKAGES:=kmod-brcmfmac cypress-firmware-43362-sdio wpad-basic-mbedtls
+  SOC := sun6i-a31
+endef
+TARGET_DEVICES += merrii_hummingbird
+
 define Device/olimex_a20-olinuxino-lime
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A20-OLinuXino-LIME