pciutils: Revert r19252's postinst changes, make $DEST a relative path
authorStephen Walker <stephendwalker@gmail.com>
Thu, 21 Jan 2010 12:58:33 +0000 (12:58 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Thu, 21 Jan 2010 12:58:33 +0000 (12:58 +0000)
SVN-Revision: 19255

utils/pciutils/Makefile
utils/pciutils/patches/102-compressed-ids.patch [new file with mode: 0644]
utils/pciutils/patches/102-zcat-pciids.patch [deleted file]
utils/pciutils/patches/103-relative-path-ids.patch [new file with mode: 0644]

index db7cd308ac2ae63f9acc402e3de47dbe2d192885..a219d68b3cd2104ab1ba03c17f20d57f0b872bd7 100644 (file)
@@ -34,7 +34,8 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
-$${IPKG_INSTROOT}/usr/sbin/update-pciids
+(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids)
+exit 0
 endef
 
 MAKE_FLAGS += \
diff --git a/utils/pciutils/patches/102-compressed-ids.patch b/utils/pciutils/patches/102-compressed-ids.patch
new file mode 100644 (file)
index 0000000..b252603
--- /dev/null
@@ -0,0 +1,31 @@
+--- a/update-pciids.sh
++++ b/update-pciids.sh
+@@ -6,9 +6,8 @@ set -e
+ SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
+ DEST=pci.ids
+ PCI_COMPRESSED_IDS=
+-GREP=grep
+-# if pci.ids is read-only (because the filesystem is read-only),
++# if pci.ids.gz is read-only (because the filesystem is read-only),
+ # then just skip this whole process.
+ if ! touch ${DEST} >/dev/null 2>&1 ; then
+       ${quiet} || echo "${DEST} is read-only, exiting." 1>&2
+@@ -18,7 +17,7 @@ fi
+ if [ -n "$PCI_COMPRESSED_IDS" ] ; then
+       DECOMP="cat"
+       SRC="$SRC.gz"
+-      GREP=zgrep
++      DEST="$DEST.gz"
+ elif which bzip2 >/dev/null 2>&1 ; then
+       DECOMP="bzip2 -d"
+       SRC="$SRC.bz2"
+@@ -53,7 +52,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
+       exit 1
+ fi
+-if ! $GREP >/dev/null "^C " $DEST.neww ; then
++if ! zcat $DEST.neww | grep >/dev/null "^C " ; then
+       echo >&2 "update-pciids: missing class info, probably truncated file"
+       exit 1
+ fi
diff --git a/utils/pciutils/patches/102-zcat-pciids.patch b/utils/pciutils/patches/102-zcat-pciids.patch
deleted file mode 100644 (file)
index c485097..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/update-pciids.sh
-+++ b/update-pciids.sh
-@@ -6,9 +6,8 @@ set -e
- SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
- DEST=pci.ids
- PCI_COMPRESSED_IDS=
--GREP=grep
--# if pci.ids is read-only (because the filesystem is read-only),
-+# if pci.ids.gz is read-only (because the filesystem is read-only),
- # then just skip this whole process.
- if ! touch ${DEST} >/dev/null 2>&1 ; then
-       ${quiet} || echo "${DEST} is read-only, exiting." 1>&2
-@@ -18,7 +17,6 @@ fi
- if [ -n "$PCI_COMPRESSED_IDS" ] ; then
-       DECOMP="cat"
-       SRC="$SRC.gz"
--      GREP=zgrep
- elif which bzip2 >/dev/null 2>&1 ; then
-       DECOMP="bzip2 -d"
-       SRC="$SRC.bz2"
-@@ -53,7 +51,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
-       exit 1
- fi
--if ! $GREP >/dev/null "^C " $DEST.neww ; then
-+if ! zcat $DEST.neww | grep >/dev/null "^C " ; then
-       echo >&2 "update-pciids: missing class info, probably truncated file"
-       exit 1
- fi
diff --git a/utils/pciutils/patches/103-relative-path-ids.patch b/utils/pciutils/patches/103-relative-path-ids.patch
new file mode 100644 (file)
index 0000000..6ccea29
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -78,7 +78,7 @@ setpci.o: setpci.c pciutils.h $(PCIINC)
+ common.o: common.c pciutils.h $(PCIINC)
+ update-pciids: update-pciids.sh
+-      sed <$< >$@ "s@^DEST=.*@DEST=$(IDSDIR)/$(PCI_IDS)@;s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
++      sed <$< >$@ "s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
+       chmod +x $@
+ # The example of use of libpci