projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0f04c9a
)
Add two debug rules the examine the values of runtime make variables. Based on patch...
author
Jo-Philipp Wich
<jow@openwrt.org>
Sun, 10 Oct 2010 22:40:44 +0000
(22:40 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Sun, 10 Oct 2010 22:40:44 +0000
(22:40 +0000)
SVN-Revision: 23389
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 49044c8cfbf4b87a8468742d4cb8abe51d62d4d9..7d3516bc4272e1186dde2ceb89145cde7c5ad19d 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-254,4
+254,16
@@
all:
FORCE: ;
.PHONY: FORCE
+val.%:
+ @$(if $(filter undefined,$(origin $*)),\
+ echo "$* undefined" >&2, \
+ echo '$(subst ','"'"',$($*))' \
+ )
+
+var.%:
+ @$(if $(filter undefined,$(origin $*)),\
+ echo "$* undefined" >&2, \
+ echo "$*='"'$(subst ','"'\"'\"'"',$($*))'"'" \
+ )
+
endif #__rules_inc