comgt: directip: add delegate option support
authorChen Minqiang <ptpt52@gmail.com>
Wed, 15 May 2024 14:57:06 +0000 (22:57 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Sep 2024 21:43:08 +0000 (23:43 +0200)
Ipv6 delegate option is not respected by proto directip
this add support for it.

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15508
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/comgt/Makefile
package/network/utils/comgt/files/directip.sh

index 429c938602709470ee8785d1e0662f91ce335493..0e826e12cdc4d26085b92a53412a334355182ed8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=35
+PKG_RELEASE:=36
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index c3b9abcad62e48f02292fe532e9c2febae3714d0..6535de936fc13cc151849ec1df1b93b31c257345 100644 (file)
@@ -16,6 +16,7 @@ proto_directip_init_config() {
        proto_config_add_string "username"
        proto_config_add_string "password"
        proto_config_add_boolean sourcefilter
+       proto_config_add_boolean delegate
        proto_config_add_defaults
 }
 
@@ -23,8 +24,8 @@ proto_directip_setup() {
        local interface="$1"
        local chat devpath devname
 
-       local device apn pincode ifname auth username password sourcefilter $PROTO_DEFAULT_OPTIONS
-       json_get_vars device apn pincode auth username password sourcefilter $PROTO_DEFAULT_OPTIONS
+       local device apn pincode ifname auth username password sourcefilter delegate $PROTO_DEFAULT_OPTIONS
+       json_get_vars device apn pincode auth username password sourcefilter delegate $PROTO_DEFAULT_OPTIONS
 
        [ -n "$ctl_device" ] && device=$ctl_device
 
@@ -90,6 +91,7 @@ proto_directip_setup() {
        json_add_string ifname "@$interface"
        json_add_string proto "dhcpv6"
        json_add_string extendprefix 1
+       [ "$delegate" = "0" ] && json_add_boolean delegate "0"
        [ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
        proto_add_dynamic_defaults
        ubus call network add_dynamic "$(json_dump)"