Dbus needs the same trick as avahi to properly disable inotify/dnotify checks with 2.4
authorFlorian Fainelli <florian@openwrt.org>
Sat, 27 Sep 2008 14:39:08 +0000 (14:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 27 Sep 2008 14:39:08 +0000 (14:39 +0000)
SVN-Revision: 12731

utils/dbus/Makefile

index 24f0997e8ef2b4db9c3955c96d9b7efcc63d4d48..087415a37388fb33df978017f9de1d030f238d2d 100644 (file)
@@ -69,7 +69,6 @@ CONFIGURE_ARGS += \
        --disable-ansi \
        --disable-asserts \
        --disable-console-owner-file \
-       --disable-dnotify \
        --disable-doxygen-docs \
        --disable-gcov \
        --disable-selinux \
@@ -85,6 +84,7 @@ CONFIGURE_ARGS += \
 
 CONFIGURE_VARS+= \
        ac_cv_have_abstract_sockets="yes" \
+       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no) \
 
 
 define Build/InstallDev