tools: mtd-utils: fix disabling tests
authorRobert Marko <robimarko@gmail.com>
Sun, 23 Jun 2024 21:52:45 +0000 (23:52 +0200)
committerRobert Marko <robimarko@gmail.com>
Tue, 25 Jun 2024 15:57:07 +0000 (17:57 +0200)
Passing --disable-tests does not do anything since upstream commit [0]
("Fix test binary installation") as that commit removed it since there is
already and existing --without-tests compile option to not compile
the tests at all as --disable-tests was just disabling their installation.

So, lets just pass --without-tests instead to disable test compilation.

[0] https://git.infraroot.at/mtd-utils.git/commit/?id=7170a28d46d5db1e7a9da24a5555a194a233ef0b

Fixes: 67efb6a66146 ("tools: mtd-utils: Update to version 2.1.4")
Link: https://github.com/openwrt/openwrt/pull/15791
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/mtd-utils/Makefile

index db96708906d62158ecbb5e8a3966e0550e983e5f..f53dbdcc4e0d0865285de8a5ec8818cdb0ea7ffe 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtd-utils
 PKG_VERSION:=2.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://infraroot.at/pub/mtd/
@@ -33,7 +33,7 @@ HOST_CONFIGURE_VARS+= \
        UUID_CFLAGS="-I$(STAGING_DIR_HOST)/include/e2fsprogs/uuid"
 
 HOST_CONFIGURE_ARGS+= \
-       --disable-tests \
+       --without-tests \
        --without-crypto \
        --without-xattr \
        --without-zstd \