projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a6f7e72
)
default to using gzip with mksquashfs if lzma and xz are unavailable
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 24 Jul 2011 09:16:55 +0000
(09:16 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 24 Jul 2011 09:16:55 +0000
(09:16 +0000)
SVN-Revision: 27748
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index c17a2cdace7cdfc0212486ca05137dcc4a574bc0..65d79f4db886f4ae104708ec4c2b3276296b1f74 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-42,6
+42,7
@@
ifneq ($(CONFIG_JFFS2_LZMA),y)
JFFS2OPTS += -x lzma
endif
+SQUASHFSCOMP := gzip
LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
ifeq ($(CONFIG_SQUASHFS_LZMA),y)
SQUASHFSCOMP := lzma $(LZMA_XZ_OPTIONS)