ramips: only limit lzma dictionary size on mt7621
authorJo-Philipp Wich <jo@mein.io>
Thu, 30 Aug 2018 08:51:09 +0000 (10:51 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 30 Aug 2018 08:58:38 +0000 (10:58 +0200)
The changed dictionary size leads to a different LZMA header which breaks
sysupgrade image magic checkibng on at least some RT288x boards.

Since the commit message only mentions testing on MT7621 and since the
change appears to break at least one other ramips subtarget, do not take
any chances and restrict the size limitation to only MT7621.

Fixes FS#1797
Fixes 09b6755946 ("ramips: limit dictionary size for lzma compression")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 77e2bccde8f7f98603f60473023dadec4f473cf6)

target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7621.mk

index cd77ffe411913c7aeac651290f8d87ae8e152558..8ab8aa3a6c9f187600cb50879ec68e7f0681583a 100644 (file)
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
 
 KERNEL_LOADADDR := $(loadaddr-y)
 
-KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
+KERNEL_DTB = kernel-bin | patch-dtb | lzma
 define Device/Default
   PROFILES = Default $$(DTS)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
index e9e2d3ecef0c5be28232266c296f7946c401617f..c8de8bd5ff7d1bec4de5c4ffd84a589892871ecb 100644 (file)
@@ -2,6 +2,7 @@
 # MT7621 Profiles
 #
 
+KERNEL_DTB += -d21
 DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
 
 define Build/elecom-wrc-factory