zynq: change location of zynq dts files
authorMieczyslaw Nalewaj <namiltd@yahoo.com>
Fri, 26 Jul 2024 00:17:57 +0000 (02:17 +0200)
committerNick Hainke <vincent@systemli.org>
Mon, 29 Jul 2024 08:32:57 +0000 (10:32 +0200)
Upstream change location of zynq dts files.

Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
target/linux/zynq/image/Makefile

index 0931871624e96db2d066c0fc911de89f1a960f69..50301cf2a834aef9458f14a1a33ca016864c87f8 100644 (file)
@@ -29,6 +29,9 @@ endef
 
 define Device/Default
        PROFILES := Default
+ifdef CONFIG_LINUX_6_6
+       DTS_DIR := $(DTS_DIR)/xilinx
+endif
        DEVICE_DTS := $(lastword $(subst _, ,$(1)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_LOADADDR := 0x8000