projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
438363c
)
bpftool: Allow to add compiler flags via EXTRA_CFLAGS variable
author
Jiri Olsa
<jolsa@kernel.org>
Mon, 8 Oct 2018 08:22:58 +0000
(10:22 +0200)
committer
Daniel Borkmann
<daniel@iogearbox.net>
Thu, 11 Oct 2018 08:24:52 +0000
(10:24 +0200)
Adding EXTRA_CFLAGS allowing user to specify extra flags
for CFLAGS variable.
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
Acked-by: Song Liu <songliubraving@fb.com>
Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
tools/bpf/bpftool/Makefile
patch
|
blob
|
history
diff --git
a/tools/bpf/bpftool/Makefile
b/tools/bpf/bpftool/Makefile
index 74288a2197abfcbf8763984516faee7f19253b50..5bfa07e3f2f7580956d503987b7d14ee52a928ce 100644
(file)
--- a/
tools/bpf/bpftool/Makefile
+++ b/
tools/bpf/bpftool/Makefile
@@
-46,6
+46,10
@@
CFLAGS += -DPACKAGE='"bpftool"' -D__EXPORTED_HEADERS__ \
-I$(srctree)/tools/lib/bpf \
-I$(srctree)/tools/perf
CFLAGS += -DBPFTOOL_VERSION='"$(BPFTOOL_VERSION)"'
+ifneq ($(EXTRA_CFLAGS),)
+CFLAGS += $(EXTRA_CFLAGS)
+endif
+
LIBS = -lelf -lbfd -lopcodes $(LIBBPF)
INSTALL ?= install