projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1146236
)
eglibc: add support for other mips64 ABI variants as well
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 31 May 2014 13:00:46 +0000
(13:00 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 31 May 2014 13:00:46 +0000
(13:00 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40890
toolchain/eglibc/common.mk
patch
|
blob
|
history
diff --git
a/toolchain/eglibc/common.mk
b/toolchain/eglibc/common.mk
index 81f3df5018e34fd2e9a266d1860377e930b853dd..9ef92c6667af0f4e80189e997396638f25de43c6 100644
(file)
--- a/
toolchain/eglibc/common.mk
+++ b/
toolchain/eglibc/common.mk
@@
-35,7
+35,15
@@
HOST_STAMP_BUILT:=$(CUR_BUILD_DIR)/.built
HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_$(VARIANT)_installed
ifeq ($(ARCH),mips64)
- TARGET_CFLAGS += -mabi=64
+ ifdef CONFIG_MIPS64_ABI_N64
+ TARGET_CFLAGS += -mabi=64
+ endif
+ ifdef CONFIG_MIPS64_ABI_N32
+ TARGET_CFLAGS += -mabi=n32
+ endif
+ ifdef CONFIG_MIPS64_ABI_O32
+ TARGET_CFLAGS += -mabi=32
+ endif
endif
EGLIBC_CONFIGURE:= \