ifeq ($(LINUX_VERSION),3.6.11)
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
endif
-ifeq ($(LINUX_VERSION),3.7.2)
- LINUX_KERNEL_MD5SUM:=a6bad0280df3bfec8f91c9aa375826a5
+ifeq ($(LINUX_VERSION),3.7.3)
+ LINUX_KERNEL_MD5SUM:=6b35fb08d229d4c6d246f27c7d475790
endif
# disable the md5sum check for unknown kernel versions
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:=
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -175,6 +175,7 @@ endif
+@@ -180,6 +180,7 @@ endif
#
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
#include <asm/uaccess.h>
#include <linux/proc_fs.h>
-@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
+@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
topt = (__be32 *)(t1 + 1);
if (ts) {
if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
fl6.flowi6_mark = skb->mark;
-@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
+@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
__be16 *p = (__be16 *)(ipv6h+1);
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
}
EXPORT_SYMBOL(bcma_core_mips_irq);
-@@ -114,8 +121,8 @@ static void bcma_core_mips_set_irq(struc
+@@ -114,7 +121,7 @@ static void bcma_core_mips_set_irq(struc
bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0),
bcma_read32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0)) &
~(1 << irqflag));
- else
-- bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(irq), 0);
+ else if (oldirq != 5)
-+ bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(oldirq), 0);
+ bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(oldirq), 0);
/* assign the new one */
- if (irq == 0) {
@@ -123,9 +130,9 @@ static void bcma_core_mips_set_irq(struc
bcma_read32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0)) |
(1 << irqflag));
#endif /* LINUX_BCMA_REGS_H_ */
--- a/drivers/net/wireless/b43/main.c
+++ b/drivers/net/wireless/b43/main.c
-@@ -4656,7 +4656,7 @@ static int b43_wireless_core_init(struct
+@@ -4684,7 +4684,7 @@ static int b43_wireless_core_init(struct
switch (dev->dev->bus_type) {
#ifdef CONFIG_B43_BCMA
case B43_BUS_BCMA:
--- a/scripts/kallsyms.c
+++ b/scripts/kallsyms.c
-@@ -83,6 +83,7 @@ static struct text_range text_ranges[] =
+@@ -54,6 +54,7 @@ static struct text_range text_ranges[] =
static struct sym_entry *table;
static unsigned int table_size, table_cnt;
static int all_symbols = 0;
static char symbol_prefix_char = '\0';
int token_profit[0x10000];
-@@ -389,6 +390,9 @@ static void write_src(void)
+@@ -360,6 +361,9 @@ static void write_src(void)
free(markers);
output_label("kallsyms_token_table");
off = 0;
for (i = 0; i < 256; i++) {
-@@ -447,6 +451,9 @@ static void *find_token(unsigned char *s
+@@ -418,6 +422,9 @@ static void *find_token(unsigned char *s
{
int i;
for (i = 0; i < len - 1; i++) {
if (str[i] == token[0] && str[i+1] == token[1])
return &str[i];
-@@ -519,6 +526,9 @@ static void optimize_result(void)
+@@ -490,6 +497,9 @@ static void optimize_result(void)
{
int i, best;
/* using the '\0' symbol last allows compress_symbols to use standard
* fast string functions */
for (i = 255; i >= 0; i--) {
-@@ -675,7 +685,9 @@ int main(int argc, char **argv)
+@@ -646,7 +656,9 @@ int main(int argc, char **argv)
if ((*p == '"' && *(p+2) == '"') || (*p == '\'' && *(p+2) == '\''))
p++;
symbol_prefix_char = *p;
} else if (argc != 1)
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -1198,6 +1198,17 @@ config KALLSYMS_ALL
+@@ -1194,6 +1194,17 @@ config KALLSYMS_ALL
Say N unless you really need all symbols.
FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
DEVICE_TYPE:=developerboard
FEATURES:=squashfs targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
+++ /dev/null
-From 107b76e67aa0447fc4ea5594823f8ffd2699fbc7 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Thu, 20 Dec 2012 14:22:38 +0100
-Subject: [PATCH] powerpc: add missing NULL terminator to avoid boot panic on
- PPC40x
-
-The missing NULL terminator can cause a panic on
-PPC405 boards during boot:
-
- Linux/PowerPC load: console=ttyS0,115200 root=/dev/mtdblock1 rootfstype=squashfs,jffs2 noinitrd init=/etc/preinit
- Finalizing device tree... flat tree at 0x6a5160
- bootconsole [udbg0] enabled
- Page fault in user mode with in_atomic() = 1 mm = (null)
- NIP = c0275f50 MSR = fffffffe
- Oops: Weird page fault, sig: 11 [#1]
- PowerPC 40x Platform
- Modules linked in:
- NIP: c0275f50 LR: c0275f60 CTR: c0280000
- REGS: c0275eb0 TRAP: 636f7265 Not tainted (3.7.1)
- MSR: fffffffe <VEC,VSX,EE,PR,FP,ME,SE,BE,IR,DR,PMM,RI> CR: c06a6190 XER: 00000001
- TASK = c02662a8[0] 'swapper' THREAD: c0274000
- GPR00: c0275ec0 c000c658 c027c4bf 00000000 c0275ee0 c000a0ec c020a1a8 c020a1f0
- GPR08: c020f631 c020f404 c025f078 c025f080 c0275f10
- Call Trace:
- ---[ end trace 31fd0ba7d8756001 ]---
-
- Kernel panic - not syncing: Attempted to kill the idle task!
-
-The panic happens since commit 9597abe00c1bab2aedce6b49866bf6d1e81c9eed
-(sections: fix section conflicts in arch/powerpc), however the root
-cause of this is that the NULL terminator were not added in commit
-a4f740cf33f7f6c164bbde3c0cdbcc77b0c4997c (of/flattree: Add of_flat_dt_match()
-helper function).
-
-Cc: Grant Likely <grant.likely@secretlab.ca>
-Cc: <stable@vger.kernel.org>
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
----
- arch/powerpc/platforms/40x/ppc40x_simple.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/arch/powerpc/platforms/40x/ppc40x_simple.c
-+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
-@@ -57,7 +57,8 @@ static const char * const board[] __init
- "amcc,makalu",
- "apm,klondike",
- "est,hotfoot",
-- "plathome,obs600"
-+ "plathome,obs600",
-+ NULL
- };
-
- static int __init ppc40x_probe(void)
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci targz broken
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
kmod-cpu-msr \
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
CS5535_MASK:=0x0E000048
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \