projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a110418
)
libmbedtls: use defaults if no build opts selected
author
Glenn Strauss
<gstrauss@gluelogic.com>
Tue, 15 Nov 2022 22:12:56 +0000
(17:12 -0500)
committer
Stijn Tintel
<stijn@linux-ipv6.be>
Wed, 16 Nov 2022 10:27:18 +0000
(12:27 +0200)
use defaults if no build opts selected
(allows build with defaults when mbedtls not selected and configured)
Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
package/libs/mbedtls/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/mbedtls/Makefile
b/package/libs/mbedtls/Makefile
index a489f56755ed0257f2af7bf02a956f26b4fb1a55..fd0f821d85823886157f87d4970043a213e218f4 100644
(file)
--- a/
package/libs/mbedtls/Makefile
+++ b/
package/libs/mbedtls/Makefile
@@
-140,10
+140,11
@@
endef
define Build/Prepare
$(call Build/Prepare/Default)
- $(foreach opt,$(MBEDTLS_BUILD_OPTS),
+ $(if $(strip $(foreach opt,$(MBEDTLS_BUILD_OPTS),$($(opt)))),
+ $(foreach opt,$(MBEDTLS_BUILD_OPTS),
$(PKG_BUILD_DIR)/scripts/config.py \
-f $(PKG_BUILD_DIR)/include/mbedtls/config.h \
- $(if $($(opt)),set,unset) $(patsubst CONFIG_%,%,$(opt)))
+ $(if $($(opt)),set,unset) $(patsubst CONFIG_%,%,$(opt)))
,)
endef
define Build/InstallDev