openssh: add ESSENTIAL_PROCESSES
authorFlorian Fainelli <florian@openwrt.org>
Fri, 27 Jul 2012 14:58:53 +0000 (14:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 27 Jul 2012 14:58:53 +0000 (14:58 +0000)
This adds an ESSENTIAL_PROCESSES shell variable to /etc/init.d/sshd.
The corresponding openwrt patch has the details.

Signed-off-by: Ryan Nowakowski <tubaman@fattuba.com>
SVN-Revision: 32889

net/openssh/Makefile
net/openssh/files/sshd.init

index 331dde82316e4e34de3d878d47b55a00eea767a3..1b8fcb3c94f6400c50c24358be7f8ddb0be9be40 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=6.0p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
index ecc44c39e4437e4a1bce9308c344d3f3e8ddb7d9..79454397454487798bcbac790e4145776ae1e952 100644 (file)
@@ -3,9 +3,11 @@
 
 START=50
 STOP=50
+ESSENTIAL_PROCESSES="ssh sshd"
 
 SERVICE_USE_PID=1
 
+
 start() {
        for type in rsa dsa; do {
                # check for keys