include/package-pack: translate PKGARCH for APK
authorRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 12:12:28 +0000 (13:12 +0100)
committerRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 18:52:03 +0000 (19:52 +0100)
We have a lot of script-only packages that are universal for all arch-s
and those set PKGARCH:=all to indicate it.

Unfortunately, APK expects architecture to be set to "noarch" instead to
indicate that its universal so instead of having to update all packages
that set PKGARCH:=all and thus break OPKG lets simply translate "all" to
"noarch" when generating the APK package.

This will be required as soon we update APK to include [1] as it will start
enforcing package architecture checks.

[1] https://gitlab.alpinelinux.org/alpine/apk-tools/-/commit/c1a3e69f24e235fc78f4dddb1f85fdf281464446

Suggested-by: Jonas Gorski <jonas.gorski@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/17015
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/package-pack.mk

index e9892f9ca613cdb15cd168561cdae819b3a23e31..3ac7a036f9de70e88a0a86eb22f8883b74e4818e 100644 (file)
@@ -344,7 +344,7 @@ else
          --info "name:$(1)$$(ABIV_$(1))" \
          --info "version:$(VERSION)" \
          --info "description:$$(call description_escape,$$(strip $$(Package/$(1)/description)))" \
-         --info "arch:$(PKGARCH)" \
+         $(if $(findstring all,$(PKGARCH)),--info "arch:noarch",--info "arch:$(PKGARCH)") \
          --info "license:$(LICENSE)" \
          --info "origin:$(SOURCE)" \
          --info "url:$(URL)" \