projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9105dad
)
cmake: fix ccache command when using host ccache (patch from #9611)
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 24 Jul 2011 08:34:08 +0000
(08:34 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 24 Jul 2011 08:34:08 +0000
(08:34 +0000)
SVN-Revision: 27742
include/cmake.mk
patch
|
blob
|
history
diff --git
a/include/cmake.mk
b/include/cmake.mk
index 6c5b5eb4f74692e893ff128ad7c99957669f0909..ad9744d3fd96289ac109534436ec77e87d488353 100644
(file)
--- a/
include/cmake.mk
+++ b/
include/cmake.mk
@@
-15,9
+15,13
@@
ifeq ($(CONFIG_CCACHE),)
CMAKE_CXX_COMPILER_ARG1:=
endif
else
- CMAKE_C_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
+ CCACHE:=$(shell which ccache)
+ ifeq ($(CCACHE),)
+ CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
+ endif
+ CMAKE_C_COMPILER:=$(CCACHE)
CMAKE_C_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CC))
- CMAKE_CXX_COMPILER:=$(
STAGING_DIR_HOST)/bin/ccache
+ CMAKE_CXX_COMPILER:=$(
CCACHE)
CMAKE_CXX_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CXX))
endif