projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6b3e162
)
jamvm: disable shared library, use the non-pic variant - makes the package much smaller
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 8 Jan 2012 23:43:39 +0000
(23:43 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 8 Jan 2012 23:43:39 +0000
(23:43 +0000)
SVN-Revision: 29700
lang/jamvm/Makefile
patch
|
blob
|
history
diff --git
a/lang/jamvm/Makefile
b/lang/jamvm/Makefile
index 374b14658e54f38a2ee7ea9e72e7e3d8ce690ec9..77dadeb64911b6b97c05903e11319a883449f9b2 100644
(file)
--- a/
lang/jamvm/Makefile
+++ b/
lang/jamvm/Makefile
@@
-44,7
+44,9
@@
endef
CONFIGURE_ARGS += \
--with-java-runtime-library=gnuclasspath \
--with-classpath-install-dir=/usr \
- --disable-int-inlining
+ --disable-int-inlining \
+ --disable-shared \
+ --without-pic
MAKE_FLAGS += \
GLIBJ_ZIP=$(STAGING_DIR)/usr/share/classpath/glibj.zip
@@
-53,7
+55,6
@@
define Package/jamvm/install
$(INSTALL_DIR) $(1)/usr
$(CP) \
$(PKG_INSTALL_DIR)/usr/bin \
- $(PKG_INSTALL_DIR)/usr/lib \
$(PKG_INSTALL_DIR)/usr/share \
$(1)/usr/
endef